cancel
Showing results for 
Search instead for 
Did you mean: 

Multi-line webhook string value changes to empty string " " as data pill

JayMappus
Deputy Chef III
Deputy Chef III

Hi,

I'm working on my first recipe. A webhook trigger has a payload with a variable name of "transcript". "Transcript" has a value string such that when I use the resulting data pill later the value is an empty string " " yet in the payload it was a multi-line string shown way below. When I use the resulting data pill as "text" rather than "formula" the value is " ".

I've tried gsub to replace line breaks and carriage returns but gsub claims the value is nil. 

Webhook Payload Value

transcript: "Lead: https://www.chatleadspro.com/l/1234

@Carlos R: Carlos R has connected

@Carlos R: Hi, alyssa. Thanks so much for reaching out to us. I'm Carlos R, a Live Chat Specialist with McDonald's

@Carlos R: Before we get started and in case we get disconnected can I get your phone number with area code and email address?

Alyssa Test: Hi, this is a test for the webhook updates.

Alyssa Test: please send through the following Alyssa Test: 333-123-1234 Alyssa Test: alyssa@testchat.com

@Carlos R: Ok, just so I’m sure your number is (333) 123-1234 and email address is null

Alyssa Test: yes, thank you

@Carlos R: Great, I am going to send this message right now.

@Carlos R: Thanks for talking with me. ",

 

Thanks in advance for any help.

Jay

2 ACCEPTED SOLUTIONS

gary1
Executive Chef II
Executive Chef II

Hi Jay, do you have other values in the payload and are they appearing as expected in your recipe? Just trying to rule out if the issue is related to the webhook and the entire payload, or if it's specific to only the "transcript" key/value. If Workato is reporting the transcript value as nil, then it's likely the issue is further upstream.

View solution in original post

JayMappus
Deputy Chef III
Deputy Chef III

Problem solved. I deleted the webhook payload field "transcript" from the payload schema and then added it back. Works like a charm. garyl thanks for making me look upstream to the webhook.

View solution in original post

6 REPLIES 6

gary1
Executive Chef II
Executive Chef II

Right on, glad you sorted it out!

marlon-muela
Workato employee
Workato employee

Hi,

This is Marlon from Customer Success. The issue appears to be a schema mismatch. Please review your webhook schema. You can update or change the schema so that it matches the actual payload from the source.