cancel
Showing results for 
Search instead for 
Did you mean: 

Salesforce Trigger Monitor Changes in Salesforce Object -Unable to receive Events for Custom Objects

pavan-narayan
Deputy Chef II
Deputy Chef II

Hi All,

Starting from Oct 31st we are facing this issues where Salesforce Connector has a Trigger "Monitor Changes in Salesforce" Object where if there is any Update or Create it will receive the event from Salesforce but we are unable to receive the events for the Custom objects at the same time it is working fine for Standard objects there was no issue receiving the event(s) for Standard objects.

Our Recipe is Production for more than 60 days and there were no issue of this kind ,this connector doesn't required any additional configuration on the Salesforce unlike the other SF Real time triggers.

We even tried to check the Permission , Limits and rest everything was all good there were no issues with the Limits and Permissions from Salesforce. Further we even tried the same exercise in different Salesforce instance created a New Custom object in SF and configured the trigger to our surprise it couldn't receive the jobs for the custom objects and working fine for standard objects .

Did anyone got this issue earlier or anyone facing this issue currently.

Thank You

#workato #salesforce #trigger #events

1 ACCEPTED SOLUTION

Hey Shiva,

Thanks for checking , Workato team has  deployed the fix this afternoon IST hours.

Last 3 days it was not working for Custom Objects.

View solution in original post

3 REPLIES 3

shivakumara
Deputy Chef III
Deputy Chef III

HI @pavan-narayan  , I've attempted to utilize the "Monitor changes in custom objects" trigger, and I successfully received events from Salesforce. I've included a link to my recipe for your review. It's possible that the issue could be attributed to technical glitches, so I recommend attempting to reconnect your connector and trying again.

https://app.workato.com/recipes/41502134?st=653ffd10f895683c79828783a550efc6d0a4788a3d4a9d1b6067b1db...

Screenshot of connector configurations.

shivakumara_0-1699354550547.png

shivakumara_1-1699354579360.png

 

Hey Shiva,

Thanks for checking , Workato team has  deployed the fix this afternoon IST hours.

Last 3 days it was not working for Custom Objects.

Ok got it. Thank you Pavan for he update.